Last Updated: Jun 18, 2018     Views: 27794

You may want to try the following steps, which should work anytime Cloud Library (formerly named 3M Cloud Library) titles or the Cloud Library app isn't working properly on iOS devices (iPad, iPhone or iPod Touch).

1.) Make sure all your apps are completely closed. Even though they may looked closed, they are not completely closed unless you follow the steps below:

For iPhone/iPad/iPod Touch Devices with iOS 7 and higher:

  • Double-click the Home button and to see a list of open apps ('Recents list').
  • Swipe each one (except your desktop) up and off the screen -- this closes all your apps.
  • Press the Home button to exit your 'Recents List'.
  • Open the Cloud Library app and try to log in. If you are able to log in, then look on your bookshelf. If you are still having trouble, then continue on to step 2...

2.) Restart your device:

  • Hold down the Power button until the 'Slide to power off' slider appears.
  • Power your device off for a minute or two.
  • Power back up by holding down the Power button until your screen lights up.

3.) Check Wi-Fi - tap Settings on your iPad and make sure you are connected to a Wi-Fi network. If you are not, tap Wi-Fi and then select a network.  Test to make sure you are connected by tapping this URL: www.bcpl.info
or open your Safari web browser and type it in.

4.) Open the Cloud Library app on your iOS device, log in and tap My Books.


5.) If the problem persists, please check your App Store and run anything found under "Updates" for the Cloud Library. THIS IS REALLY IMPORTANT!

6.) If no updates to Cloud Library are found, check to see if your iPad/iPhone software is up to date by going into go into your device "Settings" > "General" > "Software Update".

7.) Try again to get your books downloaded and if the problem persists, go into your device Settings > ibooks > and turn off "sync collections".

7.) If the problem still persists, delete the Cloud Library app and reinstall it from the App Store.

If that still does not cure the issue, please email us via BCPL's Downloadables Support Request Form and answer the following questions:

A.) Have you successfully used the Cloud Library app on your iPad/iPhone before now or is this your first try at installing the app and downloading Cloud Library books?

B.) What version number of the Cloud Library app do you have? This can be found by opening the app and tapping "About", then look for the numbers just below the red, Cloud Library.  It should look something like this: Version 3.0.7 Sep 28 2016.

C.) What version number of iOS do you have?  To find your iOS version number, tap "Settings > "General" > "Software Update".  It should look something like this: iOS 10.0.2

Comments (6)

  1. Hello. I had the same problem. I went to settings->ibooks and then, turned off "sync collections". After this, i was able to download all of the books properly. I hope it helps. All the best.
    by Shikhar on Jul 20, 2017.
  2. The suggestion from Shikhar was just what I needed. So appreciate the time people take to help others. Thank you!
    by K3 Teacher on Jun 12, 2018.
  3. I tried all of the solutions several times. The only one that worked for me was deleting the app and reinstalling it.
    by terese on Jul 11, 2018.
  4. Deleting the app and reinstalling it worked for me too. None of the other suggestions did. Thanks!
    by Teen on Aug 03, 2018.
  5. Deleted and reloaded the app and finally got my book to download after getting a weird msg about a bad authorization. Ty
    by Ksd on Sep 24, 2018.
  6. I solved this by redownloading iBooks - it had been offloaded by iOS. As soon as the download of iBooks was complete CloudLibrary worked properly.
    by Nthev on Oct 22, 2018.